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HelpGuru Documentation

Getting Started

To install the theme you must have WordPress already installed on your server.

Please consult the WordPress installation guide or your web host provider for

help with this.

Need help choosing a website host for your new site? See our

Recommended WordPress Web Hosting providers

Upgrade Note: If you are upgrading from an older version of HelpGuru,

be sure to read and follow the HelpGuru Upgrade Documentation

1. Theme Installation

On purchase, you can download HelpGuru from your Downloads section on

ThemeForest, you'll need to download the complete theme package with the

All files & documentation Download option and extract the helpguru.zip

installable theme contained in the package to start the installation process.

Regular License

HelpGuru - A Self-Service
Knowledge Base WordPress
Theme All files & documentation p with

Installable WordPress file only

Your support has expired. Renew support now! License certificate & purchase code (PDF

L Get notified by email if this item is updated License certificate & purchase code (text
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The theme can be installed using either of the following two methods:

e WordPress Upload (recommended): In the WordPress admin panel
navigate to Appearance > Add New Themes > Upload. Go to browse and
select the zipped theme folder. Press install now and the theme will be
uploaded and installed. This is the helpguru.zip extracted . If you get a
missing style.css error, you will first need to extract helpguru.zip

installable theme first.

e FTP Upload: Using your FTP program upload the un-zipped theme folder
into the /wp-content/themes/ folder of your WordPress installation.

Once the theme is uploaded, you need to activate it. Go to Appearance >

Themes and activate your theme.

Add Themes srowse

If you have a theme in a .zip format, you may install it by uploading it here.

1 Choose file helpguru-v1.6.0.zip nstall Now
pearance

Themes

Forms
Pages
Comments

Knowledge Base

> Appearance HeIpGurU

Themes
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HelpGuru

J Plugins

2. Install and Activate Required Plugins

Upon activation, you will be prompted to install HelpGuru Knowledge Base
and (optionally) bbPress. These are plugins which enable the functionality of

the Knowledge Base and the Forums features of this theme.

Select Begin installing plugins and select all the plugins and then install from
the drop down. Click Apply. The plugins will be downloaded where
appropriate. When the message appears again, return to the install required

plugins page and activate each of the plugins in turn.

& Dashboard Themes o Add New

Posts
1 Media This theme requires the following plugin: HelpGuru Knowledge Base.
o
This theme recommends the following plugin: bbPress.
B Pages I

L m : ismiss thi .
Comments

New theme activated. Visit site

> Appearance

Themes
| 2

Teventy Fifteen

Theme De*talls

The Myth of the Pier

v Plugins @
w Users

Tools
Active: HelpGu Customize Twenty Fifteen

g Settings

Install Required Plugins

All(2) | ToInstall (2)

Rulk Actione +l | Annlu
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e TR

B Plugin Source Type

(] HelpGuru Knovﬂsdge Base Pre-Packaged Required
Install

[E bbPress WordPress Repository Recommended
Install

@ Plugin Source Type

Bulk Actions j Apply

3. Setting up the HelpGuru Knowledge Base

Once your have installed and activated the plugins you will them be able to

setup your knowledge base.

You can add content now, either by using the Set Up Sample Knowledge Base

button from the Welcome screen, Installing the HelpGuru demo content (see

later section) or start creating your own content.

HelpGuru includes a dedicated Knowledge Base plugin, designed for this

theme. We do not offer support for the HelpGuru Knowledge Base

without HelpGuru as the active theme.

Welcome to HelpGururKnowledge Base

Welcome to HelpGuru Knowledge Base 3.0.0, thanks for choosing this plugin, which adds a feature

rich knowledge base to your WordPress powered site.
Getting Started

Knowledge Base basics

1. Your Knowledge Base is now available from The Knowledge Base
Archive, though it does not have anything in it at the moment.

2. Add a new article to create your first Knowledge Base article. These
work like other WordPress posts.

3. To get the most out of your Knowledge Base you should use several
top-level Knowledge Base categories to organize your Knowledge
Base.

prance 4 Tanc far the Knowledae Race will heln uicer< find relevant and related

Sample Content

Install sample articles to get an instant Knowledge Base, meaning you
experiment with example articles, categories and tags to get up and r
quickly.

Set Up Sample Knowledge Base
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content.

5. You can control most options for the Knowledge Base from the
Knowledge Base Settings page

6. The in-built live search allows users to quickly find answers to their
queries right from any page on the Knowledge Base. It also searches
Knowledge Base categories and Knowledge Base tags.

Article Addnew Articie

Al

The title, tagline and sidebar position for the HelpGuru knowledge base
section can be controlled from the theme customizer in Appearance >
Customize > Knowledge Base.

The settings for the HelpGuru knowledge base, can be found in Knowledge
Base > Settings.

General Settings

Control the overall settings for the knowledge base, including

Breadcrumbs display

Sort By

Sort Order

Number of Articles

Archive Settings

Settings for the main knowledge base archive, including
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Number of columns

Display article count

Number of articles to display in archive

Display subcategories

Subcategory depth

Display subcategory articles

Hide empty categories
Article Settings

Display options for the articles, including

e Fnable comments

Display article usefulness

Display article views

Display comment count

Display related articles
Search Settings

Options for live search functionality, including

e Enable live search
e Focus live search on page load
e Search placeholder text

e Display search result excerpt
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Set slugs for the knowledge base, including

e Articles slug
e Article Categories slug

e Article Tags slug

Custom Style

Text entry for small style snippets to the knowledge base (or sitewide), note it

recommend to use a customized child theme for modifications.

Article Feedback Settings

Article Feedback

Options for article feedback, including

Enable feedback

Enable anonymous feedback

Collect upvote feedback

Collect downvote feedback

Transfers Settings

Options for capturing transfers/visits to external help or ticketing systems,

including

e Default transfer URL

e | oad transfer links in new window

7 of 22



HelpGuru Documentation - HeroThemes

8 of 22

3] Media HelpGuru Knowledge Base Settings

Pages

General Archive Article Search Slugs Custom Style Article Feedback Transfers
P Comments

Knowledge Base General Options
Breadcrumbs Display breadcrumbs in knowledge base
Sort By Date :]

Sort order for display of knowledge base articles

Sort Order Ascending _']

Sort direction for display of knowledge base articles

Number of Articles 5

Number of articles to display for each category or tag from taxonomy archive
Save Changes

Plugins @8

» Users
Tools

Settings

4. Setting up bbPress forums

This theme supports bbPress, a popular forum plugin for WordPress. With

bbPress you can add forums to your Hero Theme powered site.

When the theme is installed and activated, you may see a naotification advising
you that bbPress is recommended plugin and prompting to install bbPress. If
this does not appear, or you want to install bbPress later search bbPress from
Plugins > Add New > Search.

Install and activate bbPress. Once installed, you will be greeted by bbPress
the welcome screen and have three new menus in your administration panel
menu — Forums, Topics and Replies. The theme will also display a link to the
forum from the front page of your site if you have the front page set up as

described below.

Create your first categories and forums by selecting Forums > New Forum, or
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install the HelpGuru demo content as described below. You and your users
can create categories, forums, topics, make replies and build a community to

complement your Hero Themes powered site.

Welcome to bbPress 2.5.10

Thank you for updat ng bbPress 2.5.10 is bundled up and ':—nad}r to weather the storm of @

users in your community! bbPl‘eﬁﬁ
Version 25.10

What's New Credits

Forum Subscriptions

Subscribe to Forums

ers can subscribe to new topics in specfic forums

Manage Subscriptions

1 manage all of their subscriptions in one convenient locatior

For additional help and support around the general use of bbPress, consult

the bbPress website.

5.1. Home Page and Blog Setup

To setup the homepage page and blog page. Simply go to Pages > Add New
and create the following pages with no content:

e Blog

e Home

For the Home page, be sure to select the custom Homepage template from
the Page Attributes metabox to ensure it uses the correct page layout.

Page Attributes

Parent

(no parent) E

Tempblate
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Homepage E

Default Template

| Homepage

0

Need help? Use the Help tab in the upper
right of your screen.

Selecting the template from the page attributes meta box

Next we need to assign these pages in WordPress as our homepage and blog
page. Go to Settings > Reading and set the settings like this:

Front page displays © Your latest posts

@ A static page (select below)
Front page: Home E
Posts page: Blog E

Controlling the front page options

5.2. Using the Knowledge Base as your Homepage

Alternatively, to use the Knowledge Base as the homepage, set Front page to

Knowledge Base Archive in Settings > Reading.
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Reading Settings

Front page displays Your latest posts
e A static page (select below)

Front page: Knowledge Base Archive v

Posts page: Blog v

Reading settings using the knowledge base as the front page

6. Import the Demo content

Contained in the HelpGuru theme package is the
helpguruwordpress.demo.xml file, which can be used to replicate the content

from the HelpGuru demo site.

Note that some manual configuration of widgets and menus is still required

and due to licensing restrictions, no images are included.

This is an optional step and only required if you are initially replicating the look
of the HelpGuru demo.

To begin installing the demo content, goto Tools > Import and select
WordPress from the list. If not installed, the WordPress Importer will be

installed.

To import the demo content, select the helpguru.wordpress.demo.xml, found in
the HelpGuru theme package. Click Upload and Import. On the next screen,
you can change the authors if you wish, otherwise click Submit to complete

the import process.

Import WordPress
Assign Authors
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r: Admin User (Admin User)

Brittani Tess (demo3)

Richard Smith (richard)

Debby Jonalle (demo1)

Thales Philibert (demod)

Import Attachments

7. Configure the Navigation Menu

To setup your custom menus, navigate to Appearance > Menus. Give your

menu a name and click Create Menu.

With the new menu you can add a variety of items including pages, categories,
custom links. To extend the available items, you many need to select the
Screen Options tab at the very top of the screen and configure the visible

items.

Once you have built and saved your menu, select Primary Navigation in the

Menu Settings section to assign the menu to the navigation area of the theme.

® Dashboard Menus Manage with Live Preview

Posts Edit Menus

41 Media

o Pages Edit your menu below, or create a new menu.
Comments

® Knowledge Base Pages = Menu Name Menu 1

Forum
e Most Recent  View All  Search Menu Structure

Topics Edit your default menu by adding or removing items. Drag each item into the order you prefer.
Sample Page

Replies

Select Al Add to Menu Home Customlink v
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Posts - Sample Page
Custom Links v
Categories .

HelpGuru Knowledge Base Archive ~

Menu Name Menu 1

Menu Structure

Drag each item into the order you prefer. Click the arrow on the right of the item to reveal additional ¢
Home stomiink v
Knowledge Base Custom Link ¥
Sample Page Page Vv

Menu Settings
Auto add pages Automatically add new top-level pages to this menu

Theme locations v/| Primary Navigation

Delete Menu

8. Configure the Widgets

Page ¥

Save Menu

onfiguration options

Save Menu

This theme features several Widgetized areas, which allow you to drag ‘n’

drop WordPress widgets which can be accessed from Appearance > Widgets.

The widgetized areas include: the default sidebar, BBPress Sidebar (if active),

Knowledge Base Sidebar, Footer Widgets and Homepage Widgets. To use a

widget in one of these areas, drag it from the Available Widgets panel on the

left into one of the boxed areas on the right. Various options can then be set,

including the title of the widget and what content appears.
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Widget availability may depend on what plugins are installed and activated.

Blog Sidebar . Footer Widgets x:
The deafult sidebar show on posts and pages Widgets shown in the footer of the theme
Categories v Text: About HelpGuru v
Recent Posts v Heroic Posts Widget: Latest News v
N Heroic Social Widget: Connect With Us v
BBPress Sidebar =
BBPress Sidebar
Homepage Widgets .
(bbPress) Login Widget v P R
(bbPress) Recent Topics: Recent Topics v Knowledge Base Articles: Popular Articles v
. Knowledge Base Articles: Most Helpful Articles v
Knowledge Base Sidebar o
Knowiedge Base Sidebar
(bbPress) Recent Topics: Popular Forum Topics v
Knowledge Base Articles: Popular Articles v
Knowledge Base Authors: Knowledge Base Authors v

9. Using your new theme

With the initial setup done, you can add/edit content. Change colors and
layout (see the customizer options in the section below), and craft your help

center.

Q Knowledge Base Q Forums ﬂ Blog

41 A 12 tege I 6 Posts

Popular Articles Knowledge Base Articles Popular Forum Topics
B What Technologies Are Used? @ Inswallation Guide O Applio is great
B Who are We? 2 What You Need to Know © Canvas user opinion

WordPress, Knowledge Base and Support

& WordPress and C55 & How to Contact Support > pu

s w = “ 9 SUp Forum in One

3 Using Javascript & How Secure is my Password Help! Issue with Applio

J What Are The AP| Limits? [@ How do | Change my Password? O WordPress and HelpGuru
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About HelpGuru Latest News Social

fya
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Configuration Options

Customizer Settings

You can customize various visual aspects of the theme using the WordPress
Live Customizer. Go to Appearance > Customize. Take some time to take a

look through the options and customize them for your site.

Header Options

e Site Title — The title for your site
e Tagline — A tagline for your site

e Site Logo — Add a custom logo, recommended size is 200px wide and
55px tall.

Footer Options
e Site Copyright — Enter your site copyright message
Styling Options

e Link Color (Hover) — Select using this color picker
e Link Color — Select using this color picker

e Header BG Color — Select the header background color using this color

picker

e Header Font Color — Select the header font color using this color picker
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e Page Header BG Color — Select the banner background color using this

color picker

e Page Header Font Color — Select the banner font color using this color

picker

Header / bbPress / Blog / Knowledge Base Options

e Headline — The headline that appears in the top banner on this page
e Tagline — A tagline for beneath the tagline on this page

e Sidebar Position — Set the position of the sidebar in these sections
(None, Left or Right)

Navigation Options

e Primary Navigation — select the menu you want to use for the main

navigation, these can be created or edited from Appearance > Menus.

Widgets (bbPress Sidebar, Knowledge Base and Footer
Widgets)

e \Widgets Shown — add/edit widgets from the live customizer. These can

also be controlled from Appearance > Widgets.

Knowleﬁge Base @ HelpGUTU KNOWLEDGE BASE

KB Title

Knowledge Base

KB Tagline

Knowledge Base

Our Knowledge Base
Our Knowledge Base

_ Ay

Sidebar Position

[

Heroic Knowledge Base Plugin i v Copyright and Legal 1 nvc

B Getting Started @ Copyright Sub One

[@ How to Contact Support [ Another Legal Page

[@ nstalation Guide [ Our Content Policy
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Getting the most out of your theme

Using Categories and Forums

When you set up the forums, it is important to consider the structure of the
forums. Setup several categories with sub-forums to ensure it looks

aesthetically pleasing.

First you need to create several forum Category types, eg General, Product
Support, Other. Into these you should put your Forum types, eg
Announcements, Feedback and Suggestions, My App Support, Their App
Support, etc. These are the sections where users can start individual

topics/threads.

Categories and Forums are created in a similar way by selecting Forums >
New Forum. The forum type is then set on the right under Forum Attributes.
Set the parent Category Types under the Type drop-down option. For forums,
select Forum as the Type and the Parent as the parent category you wish the

forum to appear.

Forum Attributes

Type: Category v

Status: Open v

Visibility:  public v

Parent:  _ No parent — v

Order: 0
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Step 1. Creating a parent category

Forum Attributes
Type: Forum v
Status: Open ¥

Visibility:  public ¥

Parent: General v

Order:

Step 2. Creating a forum in the parent category

The bbPress forums on the HelpGuru demo forums site are configured with
two parent Categories — General and Product Support. In each of these there
are several Forums — Announcements, Feedback and Suggestions, Tulip App
Support, Producto Support, Applio Support.

FOrums new Farum

All

The configuration of the forums on the demo site
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This results in a structured appearance in the community forums section of the

site.

@ He'pGuru HOME KNOWLEDGE BASE FORUMS NEWS CONTACT

Community Forums

BBPress integrated forums, perfect for staff to customer interaction.

Homepage / Forums

General
The General forum Debby Jonelle
Log Out

Announcements Topics: 2 TNT & FedEx
All announcements will appear in this forum Posts: 1 2 months, 1 week ago

Recent Topics
Feedback & Suggestions ﬂ'-fw:: Reply To: Canvas user opinion O TNT & FedEx
We listed to our customers. Post your feedback in this forum, "9%% < 2 months, 2 weeks ago

O Appho is great

¢ Canvas user opinion
Product Support

)  WordPress. Knowledge Base

Forums for individual product support topics and Support Forum in One

Tulip App Support Topics: 2 Cut down s ort costs O Help! issue with Applio
Support for the Tulip App Posts mon

Producto Support Topics: 2 Reply To: WordPress, Knowledge Forum Statistics
Support for our Producto platform Posts: 3 Base and Support Forum
ok Registered Users L
Forums 7
Topics 10
Annlia Sunnart Topics: 2 Anolio is great

The appearance of the forums on the demo site

Featured Images

The theme supports the use of featured images. The theme supports auto-
resizing of the featured images. Auto-resizing will only occur however when
the image is uploaded for the first time, images that have previously been
uploaded will not be resized. You can however use the Regenerate

Thumbnails plugin to regenerate the thumbnails to fix this.

To upload a post thumbnail, go to Posts > Add New or open an existing post in
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editing mode. Locate the Featured Image module and click the Set featured

image link.

Clicking the link will open up the WordPress image uploader where you will
upload your image. Simply make sure that it is either the same size or larger
than what the final thumbnail will be. Once you’re done uploading the image,
simply click the link that says “Set Featured Image”, which is next to the button

to insert it into the post.

For more on how to use the WordPress’ Post Thumbnail feature, please see

this article from WordPress on featured image support.

Homepage Menu Blocks

HelpGuru’s homepage varies depending on whether the forum is active, it

does not display a forum link if bbPress is not installed/activated.

To change the blocks you will need to customize the Homepage template,

please refer to our guide on customizing your theme.



